Thanks for the questions

I usually do this when I don’t really want to deal with naming new components. I get annoyed with building components up with variables because I always end up with names like PeopleList, PeopleListBase PeopleListBaseComponent, you see where that rabbit hole goes?

Usually my rule of thumb is single component files

`export default PeopleContainer(PeopleList)` because my component here is a PeopleList that is being enhanced by a container. But at the end of the day its still the entity that is a PeopleList.

hahah does that make sense? i know its super meta.

So the whole let PeopleList and reassigning it is just out of laziness on my part. I didn’t want to deal with making another file and wanted to keep the whole tutorial in one

You are correct that we are making a smart component out of a visual component and container components. You can def write this as const = …


Software Engineer at Workpop, Inc.

Get the Medium app

A button that says 'Download on the App Store', and if clicked it will lead you to the iOS App store
A button that says 'Get it on, Google Play', and if clicked it will lead you to the Google Play store